243 lines
6.6 KiB
Bash
243 lines
6.6 KiB
Bash
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
|
# Maintainer: Cyber Knight (cyberknight777) <cyberknight755@gmail.com>
|
|
# Maintainer: Venkatesh Chaturvedi (Blaster4385) <venkateshchaturvedi12@gmail.com>
|
|
|
|
pkgbase=linux-IllusionX
|
|
pkgver=6.11.IllusionX
|
|
pkgrel=1
|
|
pkgdesc='Linux'
|
|
url='https://git.tablaster.dev/Blaster4385/linux-IllusionX'
|
|
arch=(x86_64)
|
|
license=(GPL-2.0-only)
|
|
makedepends=(
|
|
bc
|
|
cpio
|
|
gettext
|
|
libelf
|
|
pahole
|
|
perl
|
|
python
|
|
tar
|
|
xz
|
|
|
|
# htmldocs
|
|
graphviz
|
|
imagemagick
|
|
python-sphinx
|
|
python-yaml
|
|
)
|
|
options=(
|
|
!debug
|
|
!strip
|
|
)
|
|
|
|
export KBUILD_BUILD_HOST=archlinux
|
|
export KBUILD_BUILD_USER=$pkgbase
|
|
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
|
|
|
|
export TC="$(pwd)/neutron-clang/bin"
|
|
export PATH="$TC:${PATH}"
|
|
|
|
FLAGS=(
|
|
LLVM=1
|
|
LLVM_IAS=1
|
|
CC="$TC"/clang
|
|
AR="$TC"/llvm-ar
|
|
LD="$TC"/ld.lld
|
|
NM="$TC"/llvm-nm
|
|
STRIP="$TC"/llvm-strip
|
|
OBJCOPY="$TC"/llvm-objcopy
|
|
OBJDUMP="$TC"/llvm-objdump
|
|
OBJSIZE="$TC"/llvm-size
|
|
HOSTCC="$TC"/clang
|
|
HOSTCXX="$TC"/clang++
|
|
HOSTAR="$TC"/llvm-ar
|
|
HOSTLD="$TC"/ld.lld
|
|
)
|
|
|
|
prepare() {
|
|
cd ../
|
|
|
|
echo "Setting config..."
|
|
|
|
make ${FLAGS[@]} archlinux_defconfig
|
|
|
|
vendor=$(lscpu | awk '/Vendor ID/{print $3}')
|
|
if [[ "$vendor" == "GenuineIntel" || "$vendor" == "AuthenticAMD" ]]; then
|
|
echo "CPU: $(lscpu | awk '/Model name/{ print substr($0, index($0,$3)) }')"
|
|
echo "Applying optimizations..."
|
|
scripts/config --disable CONFIG_GENERIC_CPU
|
|
scripts/config --set-val CONFIG_NR_CPUS $(nproc --all)
|
|
|
|
if [[ "$vendor" == "GenuineIntel" ]]; then
|
|
scripts/config --enable CONFIG_MNATIVE_INTEL
|
|
elif [[ "$vendor" == "AuthenticAMD" ]]; then
|
|
scripts/config --enable CONFIG_X86_AMD_PSTATE
|
|
scripts/config --enable CONFIG_MNATIVE_AMD
|
|
fi
|
|
fi
|
|
|
|
make -s kernelrelease > version
|
|
echo "Prepared $pkgbase version $(<version)"
|
|
}
|
|
|
|
build() {
|
|
cd ../
|
|
|
|
if ! command -v ccache &> /dev/null; then
|
|
make all -j$(nproc --all) ${FLAGS[@]}
|
|
else
|
|
PATH="/usr/lib/ccache/bin:${PATH}" make all -j$(nproc --all) ${FLAGS[@]}
|
|
fi
|
|
}
|
|
|
|
_package() {
|
|
pkgdesc="The $pkgdesc kernel and modules"
|
|
depends=(
|
|
coreutils
|
|
initramfs
|
|
kmod
|
|
)
|
|
optdepends=(
|
|
'wireless-regdb: to set the correct wireless channels of your country'
|
|
'linux-firmware: firmware images needed for some devices'
|
|
)
|
|
provides=(
|
|
KSMBD-MODULE
|
|
VIRTUALBOX-GUEST-MODULES
|
|
WIREGUARD-MODULE
|
|
)
|
|
replaces=(
|
|
virtualbox-guest-modules-arch
|
|
wireguard-arch
|
|
)
|
|
|
|
cd ../
|
|
local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
|
|
|
|
echo "Installing boot image..."
|
|
# systemd expects to find the kernel here to allow hibernation
|
|
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
|
|
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
|
|
|
|
# Used by mkinitcpio to name the kernel
|
|
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
|
|
|
|
echo "Installing modules..."
|
|
ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
|
|
DEPMOD=/doesnt/exist modules_install # Suppress depmod
|
|
|
|
# remove build link
|
|
rm "$modulesdir"/build
|
|
}
|
|
|
|
_package-headers() {
|
|
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
|
|
depends=(pahole)
|
|
|
|
cd ../
|
|
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
|
|
|
|
echo "Installing build files..."
|
|
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
|
|
version vmlinux
|
|
install -Dt "$builddir/kernel" -m644 kernel/Makefile
|
|
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
|
|
cp -t "$builddir" -a scripts
|
|
|
|
# required when STACK_VALIDATION is enabled
|
|
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
|
|
|
|
echo "Installing headers..."
|
|
cp -t "$builddir" -a include
|
|
cp -t "$builddir/arch/x86" -a arch/x86/include
|
|
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
|
|
|
|
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
|
|
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
|
|
|
|
# https://bugs.archlinux.org/task/13146
|
|
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
|
|
|
|
# https://bugs.archlinux.org/task/20402
|
|
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
|
|
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
|
|
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
|
|
|
|
# https://bugs.archlinux.org/task/71392
|
|
install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
|
|
|
|
echo "Installing KConfig files..."
|
|
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
|
|
|
|
echo "Removing unneeded architectures..."
|
|
local arch
|
|
for arch in "$builddir"/arch/*/; do
|
|
[[ $arch = */x86/ ]] && continue
|
|
echo "Removing $(basename "$arch")"
|
|
rm -r "$arch"
|
|
done
|
|
|
|
echo "Removing documentation..."
|
|
rm -r "$builddir/Documentation"
|
|
|
|
echo "Removing broken symlinks..."
|
|
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
|
|
|
|
echo "Removing loose objects..."
|
|
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
|
|
|
|
echo "Stripping build tools..."
|
|
local file
|
|
while read -rd '' file; do
|
|
case "$(file -Sib "$file")" in
|
|
application/x-sharedlib\;*) # Libraries (.so)
|
|
strip -v $STRIP_SHARED "$file" ;;
|
|
application/x-archive\;*) # Libraries (.a)
|
|
strip -v $STRIP_STATIC "$file" ;;
|
|
application/x-executable\;*) # Binaries
|
|
strip -v $STRIP_BINARIES "$file" ;;
|
|
application/x-pie-executable\;*) # Relocatable binaries
|
|
strip -v $STRIP_SHARED "$file" ;;
|
|
esac
|
|
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
|
|
|
|
echo "Stripping vmlinux..."
|
|
strip -v $STRIP_STATIC "$builddir/vmlinux"
|
|
|
|
echo "Adding symlink..."
|
|
mkdir -p "$pkgdir/usr/src"
|
|
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
|
|
}
|
|
|
|
_package-docs() {
|
|
pkgdesc="Documentation for the $pkgdesc kernel"
|
|
|
|
cd ..
|
|
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
|
|
|
|
echo "Installing documentation..."
|
|
local src dst
|
|
while read -rd '' src; do
|
|
dst="${src#Documentation/}"
|
|
dst="$builddir/Documentation/${dst#output/}"
|
|
install -Dm644 "$src" "$dst"
|
|
done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
|
|
|
|
echo "Adding symlink..."
|
|
mkdir -p "$pkgdir/usr/share/doc"
|
|
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
|
|
}
|
|
|
|
pkgname=(
|
|
"$pkgbase"
|
|
"$pkgbase-headers"
|
|
)
|
|
for _p in "${pkgname[@]}"; do
|
|
eval "package_$_p() {
|
|
$(declare -f "_package${_p#$pkgbase}")
|
|
_package${_p#$pkgbase}
|
|
}"
|
|
done
|
|
|
|
# vim:set ts=8 sts=2 sw=2 et:
|